const regex = /\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\s*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\\s*', 'gim')
const str = `rape grape g rape ra pe rapes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}