use strict;
my $str = 'rape grape g rape ra pe rapes';
my $regex = qr/\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\s*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}