$re = '/id=[0-9]{5} /';
$str = 'hsyhid=00989
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);