package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`id=[0-9]{5} `)
var str = `hsyhid=00989
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}