using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id=[0-9]{5} ";
string input = @"hsyhid=00989
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}