// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[([^]]*)\]").unwrap();
let string = "[EtlRowId]
,[PartitionKey]
,[RowKey]
,[Timestamp]
,[LoadDTS]
,[Microsoft_VSTS_Common_BacklogPriority]
,[Microsoft_VSTS_Common_Priority]
,[Microsoft_VSTS_Common_ValueArea]
,[Microsoft_VSTS_Scheduling_Effort]
,[System_AreaPath]
,[System_BoardColumn]
,[System_BoardColumnDone]
,[System_ChangedBy]
,[System_ChangedDate]
,[System_CommentCount]
,[System_CreatedBy]
,[System_CreatedDate]
,[System_IterationPath]
,[System_Reason]
,[System_State]
,[System_Tags]
,[System_TeamProject]
,[System_Title]
,[System_WorkItemType]
,[TeamNowCustomerId]
,[fields]
,[id]
,[projectId]
,[projectName]
,[rev]
,[url]
,[Microsoft_VSTS_Common_ClosedDate]
,[System_AssignedTo]
,[BugIterationHash]
,[TeamIterationHash]
,[BugHash]";
let substitution = "MAX(LEN([${1}])) AS [${1}]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}