import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^]]*)\\]";
final String string = "[EtlRowId]\n"
+ " ,[PartitionKey]\n"
+ " ,[RowKey]\n"
+ " ,[Timestamp]\n"
+ " ,[LoadDTS]\n"
+ " ,[Microsoft_VSTS_Common_BacklogPriority]\n"
+ " ,[Microsoft_VSTS_Common_Priority]\n"
+ " ,[Microsoft_VSTS_Common_ValueArea]\n"
+ " ,[Microsoft_VSTS_Scheduling_Effort]\n"
+ " ,[System_AreaPath]\n"
+ " ,[System_BoardColumn]\n"
+ " ,[System_BoardColumnDone]\n"
+ " ,[System_ChangedBy]\n"
+ " ,[System_ChangedDate]\n"
+ " ,[System_CommentCount]\n"
+ " ,[System_CreatedBy]\n"
+ " ,[System_CreatedDate]\n"
+ " ,[System_IterationPath]\n"
+ " ,[System_Reason]\n"
+ " ,[System_State]\n"
+ " ,[System_Tags]\n"
+ " ,[System_TeamProject]\n"
+ " ,[System_Title]\n"
+ " ,[System_WorkItemType]\n"
+ " ,[TeamNowCustomerId]\n"
+ " ,[fields]\n"
+ " ,[id]\n"
+ " ,[projectId]\n"
+ " ,[projectName]\n"
+ " ,[rev]\n"
+ " ,[url]\n"
+ " ,[Microsoft_VSTS_Common_ClosedDate]\n"
+ " ,[System_AssignedTo]\n"
+ " ,[BugIterationHash]\n"
+ " ,[TeamIterationHash]\n"
+ " ,[BugHash]";
final String subst = "MAX(LEN([${1}])) AS [${1}]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}