const regex = /\[([^]]*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^]]*)\\]', 'gm')
const str = `[EtlRowId]
,[PartitionKey]
,[RowKey]
,[Timestamp]
,[LoadDTS]
,[Microsoft_VSTS_Common_BacklogPriority]
,[Microsoft_VSTS_Common_Priority]
,[Microsoft_VSTS_Common_ValueArea]
,[Microsoft_VSTS_Scheduling_Effort]
,[System_AreaPath]
,[System_BoardColumn]
,[System_BoardColumnDone]
,[System_ChangedBy]
,[System_ChangedDate]
,[System_CommentCount]
,[System_CreatedBy]
,[System_CreatedDate]
,[System_IterationPath]
,[System_Reason]
,[System_State]
,[System_Tags]
,[System_TeamProject]
,[System_Title]
,[System_WorkItemType]
,[TeamNowCustomerId]
,[fields]
,[id]
,[projectId]
,[projectName]
,[rev]
,[url]
,[Microsoft_VSTS_Common_ClosedDate]
,[System_AssignedTo]
,[BugIterationHash]
,[TeamIterationHash]
,[BugHash]`;
const subst = `MAX(LEN([${1}])) AS [${1}]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);