import Foundation
let pattern = #"^([12]\d)?(\d\d)[\.\/\-](0?[1-9]|1[012])[\.\/\-](0?[1-9]|[12]\d|3[01])\s([01]?[0-9]|2[0-3]):[0-5][0-9]$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2013.11.04 11:50"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}