use strict;
my $str = '2013.11.04 11:50';
my $regex = qr/^([12]\d)?(\d\d)[\.\/\-](0?[1-9]|1[012])[\.\/\-](0?[1-9]|[12]\d|3[01])\s([01]?[0-9]|2[0-3]):[0-5][0-9]$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}