$re = '/^([12]\d)?(\d\d)[\.\/\-](0?[1-9]|1[012])[\.\/\-](0?[1-9]|[12]\d|3[01])\s([01]?[0-9]|2[0-3]):[0-5][0-9]$/';
$str = '2013.11.04 11:50';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);