re = /\D{4,}/m
str = 'gfhfghk,7878lll,
ytyC2356 -6666fggg
gvvbjh,8787
gvvbjh, co-worker
454556'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end