package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\D{4,}`)
var str = `gfhfghk,7878lll,
ytyC2356 -6666fggg
gvvbjh,8787
gvvbjh, co-worker
454556`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}