$re = '/\D{4,}/m';
$str = 'gfhfghk,7878lll,
ytyC2356 -6666fggg
gvvbjh,8787
gvvbjh, co-worker
454556';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);