// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?(DEFINE)
(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])
)
(
10\.
((?&bit)\.){2}((?&bit))
)|
(
172\.
(
(1[6-9])|
(2[0-9])|
(3[0-6])
)
\.
((?&bit)\.?+){2}
)|
(
192\.168\.
((?&bit)\.?+){2}
)").unwrap();
let string = "172.31.253.126";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}