re = /(?(DEFINE)
(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])
)
(
10\.
((?&bit)\.){2}((?&bit))
)|
(
172\.
(
(1[6-9])|
(2[0-9])|
(3[0-6])
)
\.
((?&bit)\.?+){2}
)|
(
192\.168\.
((?&bit)\.?+){2}
)/x
str = '172.31.253.126'
# Print the match result
str.match(re) do |match|
puts match.to_s
end