import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ "(?<bit>[0-1][0-9]{1,2}|2[0-4][0-9]|25[0-5])\n"
+ ")\n"
+ "(\n"
+ " 10\\.\n"
+ " ((?&bit)\\.){2}((?&bit))\n"
+ ")|\n"
+ "(\n"
+ " 172\\.\n"
+ " (\n"
+ " (1[6-9])|\n"
+ " (2[0-9])|\n"
+ " (3[0-6])\n"
+ " )\n"
+ " \\.\n"
+ " ((?&bit)\\.?+){2}\n"
+ ")|\n"
+ "(\n"
+ " 192\\.168\\.\n"
+ " ((?&bit)\\.?+){2}\n"
+ ")";
final String string = "172.31.253.126";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}