re = /^[a-zA-Z]{2,50}\s[a-zA-Z]{2,50}(-[a-zA-Z]{2,50})?$/
str = 'HJHFGJHG HGJHJ-JFHJHG'
# Print the match result
str.match(re) do |match|
puts match.to_s
end