#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[a-zA-Z]{2,50}\s[a-zA-Z]{2,50}(-[a-zA-Z]{2,50})?$"
Local $sString = "HJHFGJHG HGJHJ-JFHJHG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")