using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]{2,50}\s[a-zA-Z]{2,50}(-[a-zA-Z]{2,50})?$";
string input = @"HJHFGJHG HGJHJ-JFHJHG";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}