$re = '/(\w+.\d+\s.\d.\d+.\d+) (\w+\s\w+\s\w+.\w+.) (\w+...\w+.\w+.\w+.\w+.\w+.)(\d+.)(\w+.\w+.\w+.)(\d+.\d+.\d+.\d+.)(.+)/';
$str = 'Jun 30 08:37:38 dev10 drupal provd-va: http://prod-va.ctg.albany.edu|1435667858|page not found|85.17.180.245|http://prod-va.ctg.albany.edu/favicon.ico||0||favicon.ico';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);