import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+.\\d+\\s.\\d.\\d+.\\d+) (\\w+\\s\\w+\\s\\w+.\\w+.) (\\w+...\\w+.\\w+.\\w+.\\w+.\\w+.)(\\d+.)(\\w+.\\w+.\\w+.)(\\d+.\\d+.\\d+.\\d+.)(.+)";
final String string = "Jun 30 08:37:38 dev10 drupal provd-va: http://prod-va.ctg.albany.edu|1435667858|page not found|85.17.180.245|http://prod-va.ctg.albany.edu/favicon.ico||0||favicon.ico";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}