const regex = /(\w+.\d+\s.\d.\d+.\d+) (\w+\s\w+\s\w+.\w+.) (\w+...\w+.\w+.\w+.\w+.\w+.)(\d+.)(\w+.\w+.\w+.)(\d+.\d+.\d+.\d+.)(.+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+.\\d+\\s.\\d.\\d+.\\d+) (\\w+\\s\\w+\\s\\w+.\\w+.) (\\w+...\\w+.\\w+.\\w+.\\w+.\\w+.)(\\d+.)(\\w+.\\w+.\\w+.)(\\d+.\\d+.\\d+.\\d+.)(.+)', '')
const str = `Jun 30 08:37:38 dev10 drupal provd-va: http://prod-va.ctg.albany.edu|1435667858|page not found|85.17.180.245|http://prod-va.ctg.albany.edu/favicon.ico||0||favicon.ico`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}