use strict;
my $str = 'http://localhost:8080/ra/2015/10160/11/115500/image(2).jpg"';
my $regex = qr/((?=ra\/[0-9]{4}\/[0-9]+\/[0-9]{2}\/[0-9]+\/\Qimage(2).jpg\E).+$)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}