using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=ra\/[0-9]{4}\/[0-9]+\/[0-9]{2}\/[0-9]+\/\Qimage(2).jpg\E).+$)";
string input = @"http://localhost:8080/ra/2015/10160/11/115500/image(2).jpg""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}