const regex = /((?=ra\/[0-9]{4}\/[0-9]+\/[0-9]{2}\/[0-9]+\/\Qimage(2).jpg\E).+$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?=ra\\\/[0-9]{4}\\\/[0-9]+\\\/[0-9]{2}\\\/[0-9]+\\\/\\Qimage(2).jpg\\E).+$)', '')
const str = `http://localhost:8080/ra/2015/10160/11/115500/image(2).jpg"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}