use strict;
my $str = '
{
stream: gogo;
move: some, reg1;
#jix mult: &num, reg2;
push: reg2;
sus : 0x20;
add : him, her;
#goto
jump: loop;
dec : him, *reg2;
#get
add : onu, buna;
jump: goto;
#mydear move: "moses", rgb[8];
save ;
end ;
}
{
move: mos, reg1;
mult: &num, reg2;
push: reg2;
int : 0x20;
#lab
add : him, her;
jump: loop;
#mos
dec: him, *reg2;
#inst
add: onu, buna;
jump: lab;
save;
end;
}
{
inc: moses, to;
#io
push: him;
#kim
jump: frame;
}
okbro () {
dec: him, beat;
#his
push: him;
jump: main;
ret; }';
my $regex = qr/(((((#)|())(([ \t\n]+|()))([a-zA-Z0-9]+)([ \t\n]+))|())((([ \t\n]+|()))((move|mult)|([a-z]+)))((([ \t\n]+|()))(:))((([ \t\n]+|()))([a-zA-Z0-9,&\* \t\"\n\[\]]+))(;))|((([ \t\n]+|()))((save|end)|([a-z]+))(([ \t\n]+|()))(;))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}