const regex = /(((((#)|())(([ \t\n]+|()))([a-zA-Z0-9]+)([ \t\n]+))|())((([ \t\n]+|()))((move|mult)|([a-z]+)))((([ \t\n]+|()))(:))((([ \t\n]+|()))([a-zA-Z0-9,&\* \t\"\n\[\]]+))(;))|((([ \t\n]+|()))((save|end)|([a-z]+))(([ \t\n]+|()))(;))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((((#)|())(([ \\t\\n]+|()))([a-zA-Z0-9]+)([ \\t\\n]+))|())((([ \\t\\n]+|()))((move|mult)|([a-z]+)))((([ \\t\\n]+|()))(:))((([ \\t\\n]+|()))([a-zA-Z0-9,&\\* \\t\\"\\n\\[\\]]+))(;))|((([ \\t\\n]+|()))((save|end)|([a-z]+))(([ \\t\\n]+|()))(;))', 'g')
const str = `
{
stream: gogo;
move: some, reg1;
#jix mult: &num, reg2;
push: reg2;
sus : 0x20;
add : him, her;
#goto
jump: loop;
dec : him, *reg2;
#get
add : onu, buna;
jump: goto;
#mydear move: "moses", rgb[8];
save ;
end ;
}
{
move: mos, reg1;
mult: &num, reg2;
push: reg2;
int : 0x20;
#lab
add : him, her;
jump: loop;
#mos
dec: him, *reg2;
#inst
add: onu, buna;
jump: lab;
save;
end;
}
{
inc: moses, to;
#io
push: him;
#kim
jump: frame;
}
okbro () {
dec: him, beat;
#his
push: him;
jump: main;
ret; }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}