$re = '/(^\s+|\s+$)/m';
$str = ' d sfdsfs
sd sdf ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;