package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\s+|\s+$)`)
var str = ` d sfdsfs
sd sdf `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}