use strict;
my $str = ' d sfdsfs
sd sdf ';
my $regex = qr/(^\s+|\s+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";