re = /[$¥£€]{0,1}(?:\d{1,10}[,. ])*\d{1,10}[$¥£€]{0,1}/
str = 'This is money 1000$'
# Print the match result
str.match(re) do |match|
puts match.to_s
end