const regex = new RegExp('[$¥£€]{0,1}(?:\\d{1,10}[,. ])*\\d{1,10}[$¥£€]{0,1}', 'u')
const str = `This is money 1000\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}