using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$¥£€]{0,1}(?:\d{1,10}[,. ])*\d{1,10}[$¥£€]{0,1}";
string input = @"This is money 1000$";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}