// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\d{5}\s?\d{5})?\s?(parcel\s?locker)\s?(\d{5}\s?\d{5})?").unwrap();
let string = "Parcel Locker 10080 88673
parcel locker 10080 88673
Parcel Locker 1008088673
parcel locker 1008088673
ParcelLocker1008088673
parcellocker1008088673
parcel locker1008088673
parcel locker 1008088673
parcel locker 10080 88673
10080 88673 Parcel Locker
10080 88673 parcel locker
1008088673ParcelLocker
1008088673parcellocker
hejsan parcel locker thug
Parcel street 1234567890
1234567890 Parcel street
Locker srteet 1234567890";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}