using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{5}\s?\d{5})?\s?(parcel\s?locker)\s?(\d{5}\s?\d{5})?";
string input = @"Parcel Locker 10080 88673
parcel locker 10080 88673
Parcel Locker 1008088673
parcel locker 1008088673
ParcelLocker1008088673
parcellocker1008088673
parcel locker1008088673
parcel locker 1008088673
parcel locker 10080 88673
10080 88673 Parcel Locker
10080 88673 parcel locker
1008088673ParcelLocker
1008088673parcellocker
hejsan parcel locker thug
Parcel street 1234567890
1234567890 Parcel street
Locker srteet 1234567890";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}