#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\d{5}\s?\d{5})?\s?(parcel\s?locker)\s?(\d{5}\s?\d{5})?"
Local $sString = "Parcel Locker 10080 88673" & @CRLF & _
"parcel locker 10080 88673" & @CRLF & _
"" & @CRLF & _
"Parcel Locker 1008088673" & @CRLF & _
"parcel locker 1008088673" & @CRLF & _
"" & @CRLF & _
"ParcelLocker1008088673" & @CRLF & _
"parcellocker1008088673" & @CRLF & _
"parcel locker1008088673" & @CRLF & _
"parcel locker 1008088673" & @CRLF & _
"parcel locker 10080 88673" & @CRLF & _
"" & @CRLF & _
"10080 88673 Parcel Locker" & @CRLF & _
"10080 88673 parcel locker" & @CRLF & _
"" & @CRLF & _
"1008088673ParcelLocker" & @CRLF & _
"1008088673parcellocker" & @CRLF & _
"hejsan parcel locker thug" & @CRLF & _
"Parcel street 1234567890" & @CRLF & _
"1234567890 Parcel street " & @CRLF & _
"Locker srteet 1234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")