import Foundation
let pattern = #"(?<year>\d{4})-(?<month>0[1-9]|1[0-2])-(?<day>0[1-9]|1[0-9]|2[0-9]|3[0-1])T(?<time>(?:[0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9](?:.\d{3})?)(?<timezone>Z|[\+\-](?:0[1-9]|1[0-2]):(?:00|15|30|45))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2015-02-07T13:28:17.239+02:00
2015-02-07T13:28:17.239+02:00
2017-00-01T00:00:00Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)