#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<year>\d{4})-(?<month>0[1-9]|1[0-2])-(?<day>0[1-9]|1[0-9]|2[0-9]|3[0-1])T(?<time>(?:[0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9](?:.\d{3})?)(?<timezone>Z|[\+\-](?:0[1-9]|1[0-2]):(?:00|15|30|45))"
Local $sString = "2015-02-07T13:28:17.239+02:00" & @CRLF & _
"2015-02-07T13:28:17.239+02:00" & @CRLF & _
"" & @CRLF & _
"2017-00-01T00:00:00Z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")