// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<year>\d{4})-(?<month>0[1-9]|1[0-2])-(?<day>0[1-9]|1[0-9]|2[0-9]|3[0-1])T(?<time>(?:[0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9](?:.\d{3})?)(?<timezone>Z|[\+\-](?:0[1-9]|1[0-2]):(?:00|15|30|45))").unwrap();
let string = "2015-02-07T13:28:17.239+02:00
2015-02-07T13:28:17.239+02:00
2017-00-01T00:00:00Z";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}