re = /^([a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+[,.]?[ ]?|[a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+['-]?)+$/
str = 'No acepta más de un espacio por palabra'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end