package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+[,.]?[ ]?|[a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+['-]?)+$`)
var str = `No acepta más de un espacio por palabra`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}