$re = '/^([a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+[,.]?[ ]?|[a-zA-Z.,-_áéíóúñÁÉÍÓÚÑ()]+[\'-]?)+$/';
$str = 'No acepta más de un espacio por palabra';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);