// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]{1,5}").unwrap();
let string = "6004
281
2812
89112
23
02891
7821
28199
96822
56615
44261
60928
72912
527
910
0011
11111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}