const regex = /[0-9]{1,5}/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{1,5}', 'mg')
const str = `6004
281
2812
89112
23
02891
7821
28199
96822
56615
44261
60928
72912
527
910
0011
11111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}