import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{1,5}";
final String string = "6004\n"
+ "281\n"
+ "2812\n"
+ "89112\n"
+ "23\n"
+ "02891\n"
+ "7821\n"
+ "28199\n"
+ "96822\n"
+ "56615\n"
+ "44261\n"
+ "60928\n"
+ "72912\n"
+ "527\n"
+ "910\n"
+ "0011\n"
+ "11111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}