re = /^((?!known-to-fail|env_browser).)*$/m
str = '["known-to-fail", "env_ci", "env_local"]
["non-exclusive", "env_browser", "env_local"]
["env_ci"]
["env_ci", "env_local", "known-to-fail"]
["env_ci", "env_local"]
[]
""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end