$re = '/^((?!known-to-fail|env_browser).)*$/m';
$str = '["known-to-fail", "env_ci", "env_local"]
["non-exclusive", "env_browser", "env_local"]
["env_ci"]
["env_ci", "env_local", "known-to-fail"]
["env_ci", "env_local"]
[]
""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);