import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!known-to-fail|env_browser).)*$";
final String string = "[\"known-to-fail\", \"env_ci\", \"env_local\"]\n"
+ "[\"non-exclusive\", \"env_browser\", \"env_local\"]\n"
+ "[\"env_ci\"]\n"
+ "[\"env_ci\", \"env_local\", \"known-to-fail\"]\n"
+ "[\"env_ci\", \"env_local\"]\n"
+ "[]\n"
+ "\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}