import Foundation
let pattern = #".*HbbTV\/1\.4\.1(\s|\t)\((.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);(\s|\t)(.*);\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Mozilla/5.0 (DirectFB; Linux armv7l) AppleWebKit/537.6+ (KHTML, like Gecko) Safari/537.6+ HbbTV/1.4.1 (;TCL; ; ; ; ;)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}